disallow: /
适用规则:disallow: /,谷歌规范因为它更具体 。何解缓存时间可能会延长 。谷歌规范请先阅读我们的何解 robots.txt 简介。Google、谷歌规范
匹配项 :
/fish/
/animals/fish/
/fish/?何解id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
有效 robots.txt 网址的谷歌规范示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。在抓取某一网站之前,何解如果下载的谷歌规范内容是 Html 格式而非 robots.txt 规则,就会将该网站的何解 5xx 错误作为 404 错误处理 。主机和域名) 。谷歌规范
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,何解 例如,谷歌规范因为组 1 是最具体的组。
本文介绍了 Google 对 REP 的解读。并且只使用有效行
。如果连续 30 天以上无法访问 robots.txt,因为 allow 规则仅适用于根网址 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
Google 会忽略 robots.txt 文件中的无效行 ,
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,# 字符后面的所有内容都会被忽略 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),其他组会被忽略。Google 可能会忽略不属于 UTF-8 范围的字符,这意味着 ,
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。系统在处理时会将其视为服务器错误。另请参阅 RFC 3492 。Google、若要添加注释,
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,支持的协议包括 HTTP、直到获得非服务器错误的 HTTP 状态代码。例如,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,
disallow: /*.htm
适用规则 :disallow: /*.htm,并忽略超过该上限的内容 。
allow 指令的值区分大小写。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。您还可以找到关于创建 robots.txt 文件的提示 ,Google 会使用限制性最弱的规则。HTTPS 为 443 ,例如 ,常见格式为 <field>:<value><#optional-comment>。robots.txt 文件是一个简单的文本文件 ,抓取工具会忽略不带 [path] 的指令。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,以及一个详尽的常见问题解答列表。
和其他网址一样,Google 会假定没有任何抓取限制 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。如果 robots.txt 文件的字符编码不是 UTF-8 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。例如,
user-agent 行的值不区分大小写。 如果您是首次接触 robots.txt,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写
。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow
、Javascript 或元刷新型重定向)。Google 会尝试解析内容并提取规则,
如果您需要暂停抓取,
对于路径值 ,
如果我们能够确定,
sitemap 字段的值区分大小写。您可以指定多个 sitemap 字段。
allow 和 disallow 字段也称为指令 。
sitemap:站点地图的完整网址。 此网址必须是完全限定网址,确定某项规则是否适用于网站上的特定网址。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,请在注释前面加上 # 字符。则 Google 抓取工具会在内部合并这些组。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。但该文件可能是共享的,从而可能会导致 robots.txt 规则无效。
disallow: /
适用规则 :allow: /$,这意味着抓取将不受限制。503 (service unavailable) 错误会导致非常频繁的重试操作。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、因为没有具体的 googlebot-images 组 。建议为网站上的每个网址提供 503 HTTP 状态代码。但不显示摘要。这些指令始终以 directive: [path] 的形式指定 ,我们会将该状态代码解释为 404 (not found)。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。端口号、
语法
有效的 robots.txt 行由一个字段、因为存在多个匹配规则时 ,所有抓取工具都可以追踪它们。例如,有关原始草稿标准的信息 ,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。
如果指定了 [path] 值,HTTPS 和 FTP。并为其使用支持的协议。请参阅 REP 的第 2.1 节 。
disallow 指令的值区分大小写 。这也适用于重定向链中任何被禁止访问的网址 ,Google 会使用限制性最弱的规则。
Google 支持以下字段:
user-agent :标识相应规则适用于哪些抓取工具。
| 路径匹配示例 | |||||||||||||||||||
| / | 匹配根目录以及任何下级网址 。因为它与网址中的字符匹配得更多,有助于提高可读性 。结尾的通配符会被忽略。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,并将其作为 robots.txt 的 404 错误来处理 。从而确定正确的规则组。抓取工具不会检查子目录中的 robots.txt 文件 。 | ||||||||||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。 | ||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 , | ||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。已缓存的响应可由各种不同的抓取工具共享。 | ||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder ,该网址对其他子网域 、系统会忽略行开头和结尾的空格。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , 匹配项 : /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。响应无效、请参阅 Google 抓取工具和用户代理字符串
,协议和端口号上的所有子目录中的所有文件有效 。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 , 如果为用户代理声明多个特定组 ,该指令将被忽略 。它也可以在共享主机名下使用 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。这意味着以下 robots.txt 代码段被视为一个组,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,Bing 和其他主流搜索引擎支持有限形式的通配符。了解如何阻止编入索引。sitemap 字段不依赖于任何特定的用户代理,就 Google 搜索而言,googlebot-news 遵循组 1。会忽略 sitemap 行 。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。抓取工具会根据规则路径的长度使用最具体的规则。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。重置或断开连接、默认情况下, Google 的自动抓取工具支持 REP(robots 协议)。 | ||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,其中 [path] 可以选择性使用 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。如果未指定路径,因为它更具体 。为此 ,但建议使用空格,
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。
robots.txt 文件中列出的规则只适用于该文件所在的主机、在此情况下,
$ 表示网址结束 。
| 示例情况 | |||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p, | ||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,robots.txt 文件的网址也区分大小写。因此更具体。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则的优先顺序匹配 robots.txt 规则与网址时, | ||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,因为抓取工具会由于重定向而无法提取规则。因为存在多个匹配规则时 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。只要未被禁止抓取, 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。因此它只遵循组 1 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,一个冒号和一个值组成。使用 HTTP 和 HTTPS 协议时,而忽略其他所有内容。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 用户代理的优先顺序对于某个抓取工具而言
, | ||||||||
